Es necesario tener el plugin de flashplayer para visualizar correctamente este sitio.
descargalo
aquí o en el ícono, si no lo tienes instalado.